Miquel Mariano
by Miquel Mariano
~1 min read

Tags

Últimamente me estoy encontrando con algunas incompatibilidades al intentar actualizar los ESXi de nuestros clientes a la versión 6.5.

Dichas incompatibilidades se deben a algunos paquetes que vienen heredados de instalaciones y versiones anteriores de ESXi y que no son compatibles con ESXi 6.5. En el Update Manager, nos aparecerá un mensaje del siguiente tipo:

La actualización contiene el siguiente conjunto de VIB en conflicto


Elimine los VIB en conflicto o utilice Image Builder para crear una imagen ISO de actualización personalizada que contenga versiones mas nuevas de los VIB en conflicto e intente actualizar nuevamente

removevib1

La solución es bien sencilla y pasa por desinstalar estos paquetes.

Para ello, utilizaremos el comando Esxcli de la siguiente manera.

1) Buscaremos el nombre del paquete incompatible:

esxcli software vib list | grep scsi-mpt3

2) Lo desinstalaremos con el siguiente comando:

esxcli software vib remove -n scsi-mpt3sas

removevib2

Una vez desinstalado, ya podremos proceder a la actualización de nuestro servidor ESXi 6.5 mediante Update Manager.

Espero que sea de vuestro interés y no dudéis en dejar un comentario con vuestras dudas o sugerencias.

¡Un abrazo!

Miquel.